
<!DOCTYPE html>
<html prefix="og: http://ogp.me/ns#" lang="en-gb" dir="ltr"
	  class='com_k2 view-item itemid-101 home j36 mm-hover'>

<head>
		<base href="http://www.oxfordamerican.org/item/1119-til-the-day-i-die-bud-welch" />
	<meta http-equiv="content-type" content="text/html; charset=utf-8" />
	<meta name="keywords" content="Blues,Music,documentary film,Bud Welch,Visions of the Blues" />
	<meta name="title" content="’Til the Day I Die: Bud Welch" />
	<meta name="author" content="Nathan Willis" />
	<meta property="og:url" content="http://www.oxfordamerican.org/item/1119-til-the-day-i-die-bud-welch" />
	<meta property="og:title" content="’Til the Day I Die: Bud Welch" />
	<meta property="og:type" content="article" />
	<meta property="og:image" content="http://www.oxfordamerican.org/media/k2/items/cache/a6e4d9622a775d7eed800918154a7577_XS.jpg" />
	<meta name="image" content="http://www.oxfordamerican.org/media/k2/items/cache/a6e4d9622a775d7eed800918154a7577_XS.jpg" />
	<meta property="og:description" content="Writing and art from or about the South. Published Quarterly." />
	<meta name="description" content="Writing and art from or about the South. Published Quarterly." />
	<title>’Til the Day I Die: Bud Welch</title>
	<link href="/templates/oa/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />
	<link href="http://www.oxfordamerican.org/component/search/?Itemid=101&amp;id=1119:til-the-day-i-die-bud-welch&amp;format=opensearch" rel="search" title="Search Oxford American" type="application/opensearchdescription+xml" />
	<link href="/templates/oa/css/bootstrap.css" rel="stylesheet" type="text/css" />
	<link href="/media/k2/assets/css/magnific-popup.css?v2.7.1" rel="stylesheet" type="text/css" />
	<link href="/media/k2/assets/css/k2.fonts.css?v2.7.1" rel="stylesheet" type="text/css" />
	<link href="/templates/oa/css/k2.css" rel="stylesheet" type="text/css" />
	<link href="/media/modals/css/bootstrap.min.css" rel="stylesheet" type="text/css" />
	<link href="/templates/system/css/system.css" rel="stylesheet" type="text/css" />
	<link href="/templates/oa/css/template.css" rel="stylesheet" type="text/css" />
	<link href="/templates/oa/css/megamenu.css" rel="stylesheet" type="text/css" />
	<link href="/templates/oa/css/off-canvas.css" rel="stylesheet" type="text/css" />
	<link href="/templates/oa/fonts/font-awesome/css/font-awesome.min.css" rel="stylesheet" type="text/css" />
	<link href="/templates/oa/css/error.css" rel="stylesheet" type="text/css" />
	<link href="//fonts.googleapis.com/css?family=Crimson+Text:400,700,700italic,400italic|Merriweather+Sans:400,700,800,300" rel="stylesheet" type="text/css" />
	<link href="/templates/oa/css/custom.css" rel="stylesheet" type="text/css" />
	<style type="text/css">


			.jo_vm_socialshare{

				float: right;

			}

			.jo_vm_socialshare iframe{				

				max-width: none;

			}

			.jo_like, .jo_send, .jo_twitter, .jo_google, .jo_linkedin, .jo_pinit, .jo_submit, .jo_addthis, .jo_vklike,  .jo_vkshare{

				float: left;

				margin: 5px;

			}

			.jo_vkshare tr, .jo_vkshare td{

				border: none;

			}

			

							

				.jo_like, .jo_send, .jo_twitter, .jo_google, .jo_linkedin, .jo_pinit, .jo_submit, .jo_addthis, .jo_vklike,  .jo_vkshare{

					height: 20px;	

				}

				.jo_like{

					width: 80px;

				}

				.jo_twitter{

					width: 90px;

				}

				.jo_google{

					width: 70px;

				}

				.jo_linkedin{

					width: 100px;

				}

				.jo_vklike{

					width: 85px;

				}
	</style>
	<script src="/media/jui/js/jquery.min.js" type="text/javascript"></script>
	<script src="/media/jui/js/jquery-noconflict.js" type="text/javascript"></script>
	<script src="/media/jui/js/jquery-migrate.min.js" type="text/javascript"></script>
	<script src="/media/k2/assets/js/jquery.magnific-popup.min.js?v2.7.1" type="text/javascript"></script>
	<script src="/media/k2/assets/js/k2.frontend.js?v2.7.1&amp;sitepath=/" type="text/javascript"></script>
	<script src="/media/modals/js/jquery.touchSwipe.min.js" type="text/javascript"></script>
	<script src="/media/modals/js/jquery.colorbox-min.js" type="text/javascript"></script>
	<script src="/media/modals/js/script.min.js?v=9.2.2.p" type="text/javascript"></script>
	<script src="/plugins/system/t3/base-bs3/bootstrap/js/bootstrap.js" type="text/javascript"></script>
	<script src="/plugins/system/t3/base-bs3/js/jquery.tap.min.js" type="text/javascript"></script>
	<script src="/plugins/system/t3/base-bs3/js/off-canvas.js" type="text/javascript"></script>
	<script src="/plugins/system/t3/base-bs3/js/script.js" type="text/javascript"></script>
	<script src="/plugins/system/t3/base-bs3/js/menu.js" type="text/javascript"></script>
	<script src="/templates/oa/js/script.js" type="text/javascript"></script>
	<script src="/media/system/js/html5fallback.js" type="text/javascript"></script>
	<script type="text/javascript">

 var modals_class = 'modal_link'; var modals_disable_on_mobile = 0; var modals_disable_on_mobile_splash = 0; var modals_mobile_max_width = 767; var modals_open_by_url = ''; var modals_defaults = { transition: 'fade',opacity: '0.7',width: '40%',maxWidth: '95%',maxHeight: '95%',fixed: 'true',current: '{current} / {total}',previous: 'previous',next: 'next',close: 'close',xhrError: 'This content failed to load.',imgError: 'This image failed to load.' }; 

	</script>
	<meta property="og:image" content="http://www.oxfordamerican.org/media/k2/items/cache/a6e4d9622a775d7eed800918154a7577_L.jpg" />
	<link href="http://www.oxfordamerican.org/media/k2/items/cache/a6e4d9622a775d7eed800918154a7577_L.jpg" rel="image_src">
	<meta property="og:title" content="’Til the Day I Die: Bud Welch" />
	<meta property="og:url" content="http://www.oxfordamerican.org/item/1119-til-the-day-i-die-bud-welch" />

	
<!-- META FOR IOS & HANDHELD -->
	<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no"/>
	<style type="text/stylesheet">
		@-webkit-viewport   { width: device-width; }
		@-moz-viewport      { width: device-width; }
		@-ms-viewport       { width: device-width; }
		@-o-viewport        { width: device-width; }
		@viewport           { width: device-width; }
	</style>
	<script type="text/javascript">
		//<![CDATA[
		if (navigator.userAgent.match(/IEMobile\/10\.0/)) {
			var msViewportStyle = document.createElement("style");
			msViewportStyle.appendChild(
				document.createTextNode("@-ms-viewport{width:auto!important}")
			);
			document.getElementsByTagName("head")[0].appendChild(msViewportStyle);
		}
		//]]>
	</script>
<meta name="HandheldFriendly" content="true"/>
<meta name="apple-mobile-web-app-capable" content="YES"/>
<!-- //META FOR IOS & HANDHELD -->




<!-- Le HTML5 shim and media query for IE8 support -->
<!--[if lt IE 9]>
<script src="//html5shim.googlecode.com/svn/trunk/html5.js"></script>
<script type="text/javascript" src="/plugins/system/t3/base-bs3/js/respond.min.js"></script>
<![endif]-->

<!-- You can add Google Analytics here or use T3 Injection feature -->
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-58621575-1', 'auto');
  ga('send', 'pageview');
</script>
<meta name="p:domain_verify" content="0151c7dd53cb7b8ac8f3b83450f660c5"/>
</head>

<body>

<div class="t3-wrapper"> <!-- Need this wrapper for off-canvas menu. Remove if you don't use of-canvas -->
<div id="header">
<div class="t3-mainnav-offset-top hidden-sm hidden-md hidden-lg">
  
<!-- MAIN NAVIGATION -->
<nav id="t3-mainnav" class="wrap navbar navbar-default t3-mainnav">
	<div class="container">

		<!-- Brand and toggle get grouped for better mobile display -->
		<div class="navbar-header">
		

							
<button class="btn btn-primary off-canvas-toggle hidden-sm hidden-md hidden-lg" type="button" data-pos="left" data-nav="#t3-off-canvas" data-effect="off-canvas-effect-3">
  Oxford American - Navigation
</button>

<!-- OFF-CANVAS SIDEBAR -->
<div id="t3-off-canvas" class="t3-off-canvas ">

  <div class="t3-off-canvas-header">
    <h2 class="t3-off-canvas-header-title">Main Menu</h2>
    <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
  </div>

  <div class="t3-off-canvas-body">
    <div class="t3-module modulesearch-bar " id="Mod121"><div class="module-inner"><div class="module-ct"><div class="searchsearch-bar">
	<form action="/" method="post" class="form-inline form-search">
		<label for="mod-search-searchword" class="element-invisible">Search ...</label> <input name="searchword" id="mod-search-searchword" maxlength="200"  class="form-control search-query" type="search" size="20" placeholder="Search ..." /> <button class="button btn btn-primary" onclick="this.form.searchword.focus();">Search</button>		<input type="hidden" name="task" value="search" />
		<input type="hidden" name="option" value="com_search" />
		<input type="hidden" name="Itemid" value="181" />
	</form>
</div>
</div></div></div><div class="t3-module module " id="Mod408"><div class="module-inner"><div class="module-ct">

<div class="custom"  >
	<!-- START: Modals --><a href="#mycontent" class="modal_link" data-modal-inline="true" data-modal-autoclose="9000" data-modal-open="true" data-modal-class-name="no_title" data-modal-title="<div class=&quot;countdown&quot;></div>"></a><!-- END: Modals --> <!-- START: Modals --><div style="display:none;"><div id="mycontent">
<div style="font-size: 14px; text-align:center;"><h3>Subscribe Today</h3>The <em>Oxford American</em> is published quarterly. Each subscription includes our annual Southern music issue, which comes with a CD.<br /><br /><a href="/subscribe" style="background: #ff5757; background-image: linear-gradient(to bottom, #ff5757, #ab0909); -webkit-border-radius: 28; -moz-border-radius: 28; border-radius: 28px; color: #ffffff; font-size: 12px; padding: 6px 8px; text-decoration: none;">Subscribe</a></div>
</div></div><!-- END: Modals --></div>
</div></div></div><div class="t3-module module " id="Mod1"><div class="module-inner"><div class="module-ct"><ul class="nav  nav-pills nav-stacked  nav-pills">
<li class="item-101 current active"><a href="/" >Home</a></li><li class="item-146"><a href="/magazine" >Magazine</a></li><li class="item-171"><a href="/music" >Music</a></li><li class="item-151"><a href="/subscribe" >Subscribe</a></li><li class="item-150 deeper dropdown parent">	<a class="dropdown-toggle" href="#"  data-toggle="dropdown">Join &amp; Give<em class="caret"></em></a><ul class="dropdown-menu"><li class="item-247">	<a href="/members" >Membership</a></li><li class="item-353"><a href="/join-and-give/donate" >Donate</a></li><li class="item-354"><a href="/join-and-give/thank-you" >Thank You</a></li></ul></li><li class="item-149">	<a href="http://store.oxfordamerican.org/" target="_blank" >Store</a></li><li class="item-108 deeper dropdown parent">	<a class="dropdown-toggle" href="#"  data-toggle="dropdown">About<em class="caret"></em></a><ul class="dropdown-menu"><li class="item-140"><a href="/about/history" >History</a></li><li class="item-142"><a href="/about/masthead" >Masthead</a></li><li class="item-154"><a href="/about/newsstand-locations" >Newsstand Locations</a></li><li class="item-141"><a href="/about/submission-guidelines" >Submissions</a></li><li class="item-368"><a href="/about/fellowship" title="fellowship" >Fellowship</a></li><li class="item-153"><a href="/about/jobs" >Jobs</a></li><li class="item-310">	<a href="/events" >Events</a></li></ul></li></ul>
</div></div></div>
  </div>

</div>
<!-- //OFF-CANVAS SIDEBAR -->

			
		</div>

					<div class="t3-navbar-collapse navbar-collapse collapse"></div>
		
		<div class="t3-navbar col-sm-10 hidden-xs">
			<div  class="t3-megamenu animate fading"  data-duration="700" data-responsive="true">
<ul itemscope itemtype="http://www.schema.org/SiteNavigationElement" class="nav navbar-nav level0">
<li itemprop='name' class="current active" data-id="101" data-level="1">
<a itemprop='url' class="" href="/"   data-target="#">Home </a>

</li>
<li itemprop='name'  data-id="146" data-level="1">
<a itemprop='url' class="" href="/magazine"   data-target="#">Magazine </a>

</li>
<li itemprop='name'  data-id="171" data-level="1">
<a itemprop='url' class="" href="/music"   data-target="#">Music </a>

</li>
<li itemprop='name'  data-id="151" data-level="1">
<a itemprop='url' class="" href="/subscribe"   data-target="#">Subscribe </a>

</li>
<li itemprop='name' class="dropdown mega" data-id="150" data-level="1">
<a itemprop='url' class=" dropdown-toggle" href="#"   data-target="#" data-toggle="dropdown">Join &amp; Give<em class="caret"></em></a>

<div class="nav-child dropdown-menu mega-dropdown-menu"  ><div class="mega-dropdown-inner">
<div class="row">
<div class="col-xs-12 mega-col-nav" data-width="12"><div class="mega-inner">
<ul itemscope itemtype="http://www.schema.org/SiteNavigationElement" class="mega-nav level1">
<li itemprop='name'  data-id="247" data-level="2">
<a itemprop='url' class="" href="/members"   data-target="#">Membership</a>

</li>
<li itemprop='name'  data-id="353" data-level="2">
<a itemprop='url' class="" href="/join-and-give/donate"   data-target="#">Donate </a>

</li>
<li itemprop='name'  data-id="354" data-level="2">
<a itemprop='url' class="" href="/join-and-give/thank-you"   data-target="#">Thank You </a>

</li>
</ul>
</div></div>
</div>
</div></div>
</li>
<li itemprop='name'  data-id="149" data-level="1">
<a itemprop='url' class="" href="http://store.oxfordamerican.org/" target="_blank"   data-target="#">Store</a>

</li>
<li itemprop='name' class="dropdown mega" data-id="108" data-level="1">
<a itemprop='url' class=" dropdown-toggle" href="#"   data-target="#" data-toggle="dropdown">About<em class="caret"></em></a>

<div class="nav-child dropdown-menu mega-dropdown-menu"  ><div class="mega-dropdown-inner">
<div class="row">
<div class="col-xs-12 mega-col-nav" data-width="12"><div class="mega-inner">
<ul itemscope itemtype="http://www.schema.org/SiteNavigationElement" class="mega-nav level1">
<li itemprop='name'  data-id="140" data-level="2">
<a itemprop='url' class="" href="/about/history"   data-target="#">History </a>

</li>
<li itemprop='name'  data-id="142" data-level="2">
<a itemprop='url' class="" href="/about/masthead"   data-target="#">Masthead </a>

</li>
<li itemprop='name'  data-id="154" data-level="2">
<a itemprop='url' class="" href="/about/newsstand-locations"   data-target="#">Newsstand Locations </a>

</li>
<li itemprop='name'  data-id="141" data-level="2">
<a itemprop='url' class="" href="/about/submission-guidelines"   data-target="#">Submissions </a>

</li>
<li itemprop='name'  data-id="368" data-level="2">
<a itemprop='url' class="" href="/about/fellowship"  title="fellowship"   data-target="#">Fellowship </a>

</li>
<li itemprop='name'  data-id="153" data-level="2">
<a itemprop='url' class="" href="/about/jobs"   data-target="#">Jobs </a>

</li>
<li itemprop='name'  data-id="310" data-level="2">
<a itemprop='url' class="" href="/events"   data-target="#">Events</a>

</li>
</ul>
</div></div>
</div>
</div></div>
</li>
</ul>
</div>

		</div>
        		<div id="search-bar" class="col-sm-2">
        	

<div class="custom"  >
	<script>
  (function() {
    var cx = '016639192344920322818:xcpzj06hp04';
    var gcse = document.createElement('script');
    gcse.type = 'text/javascript';
    gcse.async = true;
    gcse.src = (document.location.protocol == 'https:' ? 'https:' : 'http:') +
        '//www.google.com/cse/cse.js?cx=' + cx;
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(gcse, s);
  })();
</script>
<gcse:searchbox-only></gcse:searchbox-only></div>

        </div>
            
	</div>
</nav>
<!-- //MAIN NAVIGATION -->

</div>
  
<div id="top" class="container hidden-xs">
	<div class="row">
		            <!-- topmenu -->
            <div class="col-xs-12 col-sm-8 col-md-10 topmenu">
                <ul class="nav  nav-pills nav-stacked ">
<li class="item-133"><a href="/contact" >Contact</a></li><li class="item-134"><a href="/newsletter" >Newsletter</a></li><li class="item-308"><a href="/events" >Events</a></li></ul>

            </div>
            <!-- //topmenu -->
            
    
		            <!-- socials -->
            <div class="col-xs-12 col-sm-4 col-md-2 socials">
                <ul class="nav  nav-pills nav-stacked ">
<li class="item-136">	<a href="https://twitter.com/oxfordamerican/" target="_blank" ><img src="/images/socials/tweeter.png" alt="Twitter" /></a></li><li class="item-137">	<a href="https://www.facebook.com/oxfordamerican" target="_blank" ><img src="/images/socials/facebook.png" alt="Facebook" /></a></li><li class="item-138">	<a href="http://instagram.com/oxfordamerican" target="_blank" ><img src="/images/socials/instagram.png" alt="Instagram" /></a></li><li class="item-139">	<a href="https://www.youtube.com/user/oxfordamerican" target="_blank" ><img src="/images/socials/video.png" alt="YouTube" /></a></li></ul>

            </div>
            <!-- //socials -->
            
        
	</div>
</div>    

<!-- HEADER -->
<header id="t3-header"><div class="container t3-header">
	<div class="container-inner">
        <div class="row">
    
            <!-- LOGO -->
            <div class="col-xs-12 col-sm-12 col-md-5 logo">
                <div class="logo-image">
                    <a href="/" title="Oxford American">
                                                    <img class="logo-img" src="/images/logo.png" alt="Oxford American" />
                                                                        <span>Oxford American</span>
                    </a>
                    <small class="site-slogan"></small>
                </div>
            </div>
            <!-- //LOGO -->
    
                            <!-- current-issue -->
                <div class="col-xs-12 col-sm-12 col-md-4 current-issue hidden-xs">
                    

<div class="custom"  >
	<h4><span style="font-size: 15pt;"><strong><br /><a href="/magazine/itemlist/category/180-issue-96-spring-2017" target="_blank">2017 SPRING ISSUE</a></strong></span></h4>
<div>&nbsp;</div>
<div style="text-align: right;">Three micro-memoirs<strong>&nbsp;</strong>by <strong>Beth Ann Fennelly </strong></div>
<div style="text-align: right;"><a href="/magazine/item/1106-a-town-under-trial">A Town Under Trial, by <strong>Nick Tabor</strong></a></div>
<div style="text-align: right;"><strong>Kiese Laymon </strong>remembers<strong> Margaret Walker</strong></div>
<div style="text-align: right;"><em>Flayed</em>, a story by <strong>Jesmyn Ward</strong></div>
<div style="text-align: right;"><span style="text-align: right;"><strong>Brian Blanchfield </strong>reads&nbsp;Guy Davenport</span><strong><br /></strong></div></div>

                </div>
                <!-- //current-issue -->
                
                            <!-- book -->
                <div class="col-xs-12 col-sm-12 col-md-3 book hidden-xs">
                    

<div class="custom"  >
	<a href="/magazine/itemlist/category/180-issue-96-spring-2017" target="_blank"><img src="/images/_ISSUECOVERS/_Module%20covers/OA96_COVER_module.jpg" alt="OA96 COVER module" /></a></div>

                </div>
                <!-- //book -->
                
    
        </div>
    </div>
</div></header>
<!-- //HEADER -->

<div class="t3-mainnav-offset hidden-xs">

  
<!-- MAIN NAVIGATION -->
<nav id="t3-mainnav" class="wrap navbar navbar-default t3-mainnav">
	<div class="container">

		<!-- Brand and toggle get grouped for better mobile display -->
		<div class="navbar-header">
		

							
<button class="btn btn-primary off-canvas-toggle hidden-sm hidden-md hidden-lg" type="button" data-pos="left" data-nav="#t3-off-canvas" data-effect="off-canvas-effect-3">
  Oxford American - Navigation
</button>

<!-- OFF-CANVAS SIDEBAR -->
<div id="t3-off-canvas" class="t3-off-canvas ">

  <div class="t3-off-canvas-header">
    <h2 class="t3-off-canvas-header-title">Main Menu</h2>
    <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
  </div>

  <div class="t3-off-canvas-body">
    <div class="t3-module modulesearch-bar " id="Mod121"><div class="module-inner"><div class="module-ct"><div class="searchsearch-bar">
	<form action="/" method="post" class="form-inline form-search">
		<label for="mod-search-searchword" class="element-invisible">Search ...</label> <input name="searchword" id="mod-search-searchword" maxlength="200"  class="form-control search-query" type="search" size="20" placeholder="Search ..." /> <button class="button btn btn-primary" onclick="this.form.searchword.focus();">Search</button>		<input type="hidden" name="task" value="search" />
		<input type="hidden" name="option" value="com_search" />
		<input type="hidden" name="Itemid" value="181" />
	</form>
</div>
</div></div></div><div class="t3-module module " id="Mod408"><div class="module-inner"><div class="module-ct">

<div class="custom"  >
	<!-- START: Modals --><a href="#mycontent" class="modal_link" data-modal-inline="true" data-modal-autoclose="9000" data-modal-open="true" data-modal-class-name="no_title" data-modal-title="<div class=&quot;countdown&quot;></div>"></a><!-- END: Modals --> <!-- START: Modals --><div style="display:none;"><div id="mycontent">
<div style="font-size: 14px; text-align:center;"><h3>Subscribe Today</h3>The <em>Oxford American</em> is published quarterly. Each subscription includes our annual Southern music issue, which comes with a CD.<br /><br /><a href="/subscribe" style="background: #ff5757; background-image: linear-gradient(to bottom, #ff5757, #ab0909); -webkit-border-radius: 28; -moz-border-radius: 28; border-radius: 28px; color: #ffffff; font-size: 12px; padding: 6px 8px; text-decoration: none;">Subscribe</a></div>
</div></div><!-- END: Modals --></div>
</div></div></div><div class="t3-module module " id="Mod1"><div class="module-inner"><div class="module-ct"><ul class="nav  nav-pills nav-stacked  nav-pills">
<li class="item-101 current active"><a href="/" >Home</a></li><li class="item-146"><a href="/magazine" >Magazine</a></li><li class="item-171"><a href="/music" >Music</a></li><li class="item-151"><a href="/subscribe" >Subscribe</a></li><li class="item-150 deeper dropdown parent">	<a class="dropdown-toggle" href="#"  data-toggle="dropdown">Join &amp; Give<em class="caret"></em></a><ul class="dropdown-menu"><li class="item-247">	<a href="/members" >Membership</a></li><li class="item-353"><a href="/join-and-give/donate" >Donate</a></li><li class="item-354"><a href="/join-and-give/thank-you" >Thank You</a></li></ul></li><li class="item-149">	<a href="http://store.oxfordamerican.org/" target="_blank" >Store</a></li><li class="item-108 deeper dropdown parent">	<a class="dropdown-toggle" href="#"  data-toggle="dropdown">About<em class="caret"></em></a><ul class="dropdown-menu"><li class="item-140"><a href="/about/history" >History</a></li><li class="item-142"><a href="/about/masthead" >Masthead</a></li><li class="item-154"><a href="/about/newsstand-locations" >Newsstand Locations</a></li><li class="item-141"><a href="/about/submission-guidelines" >Submissions</a></li><li class="item-368"><a href="/about/fellowship" title="fellowship" >Fellowship</a></li><li class="item-153"><a href="/about/jobs" >Jobs</a></li><li class="item-310">	<a href="/events" >Events</a></li></ul></li></ul>
</div></div></div>
  </div>

</div>
<!-- //OFF-CANVAS SIDEBAR -->

			
		</div>

					<div class="t3-navbar-collapse navbar-collapse collapse"></div>
		
		<div class="t3-navbar col-sm-10 hidden-xs">
			<div  class="t3-megamenu animate fading"  data-duration="700" data-responsive="true">
<ul itemscope itemtype="http://www.schema.org/SiteNavigationElement" class="nav navbar-nav level0">
<li itemprop='name' class="current active" data-id="101" data-level="1">
<a itemprop='url' class="" href="/"   data-target="#">Home </a>

</li>
<li itemprop='name'  data-id="146" data-level="1">
<a itemprop='url' class="" href="/magazine"   data-target="#">Magazine </a>

</li>
<li itemprop='name'  data-id="171" data-level="1">
<a itemprop='url' class="" href="/music"   data-target="#">Music </a>

</li>
<li itemprop='name'  data-id="151" data-level="1">
<a itemprop='url' class="" href="/subscribe"   data-target="#">Subscribe </a>

</li>
<li itemprop='name' class="dropdown mega" data-id="150" data-level="1">
<a itemprop='url' class=" dropdown-toggle" href="#"   data-target="#" data-toggle="dropdown">Join &amp; Give<em class="caret"></em></a>

<div class="nav-child dropdown-menu mega-dropdown-menu"  ><div class="mega-dropdown-inner">
<div class="row">
<div class="col-xs-12 mega-col-nav" data-width="12"><div class="mega-inner">
<ul itemscope itemtype="http://www.schema.org/SiteNavigationElement" class="mega-nav level1">
<li itemprop='name'  data-id="247" data-level="2">
<a itemprop='url' class="" href="/members"   data-target="#">Membership</a>

</li>
<li itemprop='name'  data-id="353" data-level="2">
<a itemprop='url' class="" href="/join-and-give/donate"   data-target="#">Donate </a>

</li>
<li itemprop='name'  data-id="354" data-level="2">
<a itemprop='url' class="" href="/join-and-give/thank-you"   data-target="#">Thank You </a>

</li>
</ul>
</div></div>
</div>
</div></div>
</li>
<li itemprop='name'  data-id="149" data-level="1">
<a itemprop='url' class="" href="http://store.oxfordamerican.org/" target="_blank"   data-target="#">Store</a>

</li>
<li itemprop='name' class="dropdown mega" data-id="108" data-level="1">
<a itemprop='url' class=" dropdown-toggle" href="#"   data-target="#" data-toggle="dropdown">About<em class="caret"></em></a>

<div class="nav-child dropdown-menu mega-dropdown-menu"  ><div class="mega-dropdown-inner">
<div class="row">
<div class="col-xs-12 mega-col-nav" data-width="12"><div class="mega-inner">
<ul itemscope itemtype="http://www.schema.org/SiteNavigationElement" class="mega-nav level1">
<li itemprop='name'  data-id="140" data-level="2">
<a itemprop='url' class="" href="/about/history"   data-target="#">History </a>

</li>
<li itemprop='name'  data-id="142" data-level="2">
<a itemprop='url' class="" href="/about/masthead"   data-target="#">Masthead </a>

</li>
<li itemprop='name'  data-id="154" data-level="2">
<a itemprop='url' class="" href="/about/newsstand-locations"   data-target="#">Newsstand Locations </a>

</li>
<li itemprop='name'  data-id="141" data-level="2">
<a itemprop='url' class="" href="/about/submission-guidelines"   data-target="#">Submissions </a>

</li>
<li itemprop='name'  data-id="368" data-level="2">
<a itemprop='url' class="" href="/about/fellowship"  title="fellowship"   data-target="#">Fellowship </a>

</li>
<li itemprop='name'  data-id="153" data-level="2">
<a itemprop='url' class="" href="/about/jobs"   data-target="#">Jobs </a>

</li>
<li itemprop='name'  data-id="310" data-level="2">
<a itemprop='url' class="" href="/events"   data-target="#">Events</a>

</li>
</ul>
</div></div>
</div>
</div></div>
</li>
</ul>
</div>

		</div>
        		<div id="search-bar" class="col-sm-2">
        	

<div class="custom"  >
	<script>
  (function() {
    var cx = '016639192344920322818:xcpzj06hp04';
    var gcse = document.createElement('script');
    gcse.type = 'text/javascript';
    gcse.async = true;
    gcse.src = (document.location.protocol == 'https:' ? 'https:' : 'http:') +
        '//www.google.com/cse/cse.js?cx=' + cx;
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(gcse, s);
  })();
</script>
<gcse:searchbox-only></gcse:searchbox-only></div>

        </div>
            
	</div>
</nav>
<!-- //MAIN NAVIGATION -->

</div>  
</div>  

  


  


  


  
<div id="t3-mainbody"><div class="t3-mainbody"><div class="container"> 
	<div class="row">

		<!-- MAIN CONTENT -->
		<div id="t3-content" class="t3-content col-xs-12 col-sm-8  col-md-9">
				        
						<div id="system-message-container">
	</div>

						<!-- START: Call to prepare extra fields --> 
    
<!-- END: Call to prepare extra fields -->

<!-- Start K2 Item Layout -->
<span id="startOfPageId1119"></span>

<div id="k2Container" class="itemView">

	<!-- Plugins: BeforeDisplay -->
	
	<!-- K2 Plugins: K2BeforeDisplay -->
			        <div class="itemCategory">
            <a href="/itemlist/category/164-video">Video</a>
        </div>
        
		  <!-- Item title -->
	  <h2 class="itemTitle">
			
	  	’Til the Day I Die: Bud Welch
	  	
	  </h2>
	  	  <div class="itemMeta">
		        <!-- Item category 
        <div class="itemCategory">
            <a href="/itemlist/category/164-video">Video</a>
        </div>-->
              
	  				<!-- Item Author -->
			<span class="itemAuthor">
				By&nbsp;
								<a rel="author" href="/itemlist/user/1231-nathanwillis">Nathan Willis</a>
							</span>
			
						<!-- Date created -->
			<span class="itemDateCreated">|&nbsp;
				March 9, 2017			</span>
			           <!-- EXTRA FIELDS --> <!-- END EXTRA FIELDS --> 
	  </div>
	  
		  <!-- Item Image -->
	  <div class="itemImageBlock">
		  <span class="itemImage">
		  	<a class="modal" rel="{handler: 'image'}" href="/media/k2/items/cache/a6e4d9622a775d7eed800918154a7577_XL.jpg" title="Click to preview image">
		  		<img src="/media/k2/items/cache/a6e4d9622a775d7eed800918154a7577_XL.jpg" alt="&rsquo;Til the Day I Die: Bud Welch" style="width:900px; height:auto;" />
		  	</a>
		  </span>

		  
		  	  </div>
	  
	  

	<div class="itemHeader">

	


  <!-- Plugins: AfterDisplayTitle -->
  
  <!-- K2 Plugins: K2AfterDisplayTitle -->
  
	  <div class="itemToolbar">
		<ul>
			
			
			
			
			
			
					</ul>
		<div class="clr"></div>
  </div>
	
	
  <div class="itemBody">

	  <!-- Plugins: BeforeDisplayContent -->
	  
	  <!-- K2 Plugins: K2BeforeDisplayContent -->
	  <div class="jo_vm_socialshare">

			<div class="jo_addthis">

				<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-506134e001e956bd" async="async"></script>				

				<div class="addthis_sharing_toolbox"></div>				

			</div></div>
	  

	  	  	  	  <!-- Item fulltext -->
	  <div class="itemFullText">
	  	<p><em>’Til the Day I Die</em> is a visual exploration of gospel and the blues, shot on Super 8mm film. Leo “Bud” Welch is an 84-year-old Mississippi bluesman who has spent most of his difficult life working on farms, cutting down trees by chainsaw, and living in a one room shack in Bruce, Mississippi. He often wonders if a better life waits for him once this life on Earth is over.</p>
<p>&nbsp;</p>
<div><iframe src="https://player.vimeo.com/video/199473377" frameborder="0" width="640" height="360" allowfullscreen="allowfullscreen" webkitallowfullscreen="" mozallowfullscreen="" style="display: block; margin-left: auto; margin-right: auto;"></iframe></div>
<div style="text-align: center;"><a href="https://vimeo.com/199473377"></a></div>
<hr />
<p>&nbsp;</p>
<p style="text-align: center;"><span style="font-size: 12.8px;">Credits:</span></p>
<p style="text-align: center;"><span style="font-size: 12.8px;">Directed, Photographed, and Edited by Nathan Willis</span></p>
<p style="text-align: center;"><span style="font-size: 12.8px;">Produced by Matthew Aughtry and Nathan Willis</span></p>
<p style="text-align: center;"><span style="font-size: 12.8px;">Special Thanks: Roger Stolle, Vencie Varnado, and Leo "Bud" Welch</span></p>
<p>&nbsp;</p>
<p style="text-align: center;"><em>For more, read the <span style="text-decoration: underline;"><a href="/magazine/itemlist/category/179-issue-95-winter-2016" target="_blank">18th Southern Music Issue: Visions of the Blues</a></span></em>.&nbsp;</p>	  </div>
	  	  
		<div class="clr"></div>

	  		  	  <!-- Item tags -->
	  <div class="itemTagsBlock">
		  <ul class="itemTags">
		    		    <li><a href="/itemlist/tag/Blues">Blues</a></li>
		    		    <li><a href="/itemlist/tag/Music">Music</a></li>
		    		    <li><a href="/itemlist/tag/documentary%20film">documentary film</a></li>
		    		    <li><a href="/itemlist/tag/Bud%20Welch">Bud Welch</a></li>
		    		    <li><a href="/itemlist/tag/Visions%20of%20the%20Blues">Visions of the Blues</a></li>
		    		  </ul>
	  </div>
	  		
	  <!-- Plugins: AfterDisplayContent -->
	  
	  <!-- K2 Plugins: K2AfterDisplayContent -->
	  
	  <div class="clr"></div>
  </div>

	
    <div class="itemLinks">

	  
		<div class="clr"></div>
  </div>
  
    <!-- Author Block -->
  <div class="itemAuthorBlock">

  	<div class="clearfix">
  		<div class="col-sm-0">
  			  		</div>
  		<div class="col-sm-12">
  			<div class="itemAuthorDetails">
		      <h3 class="itemAuthorName">
		      	<a rel="author" href="/itemlist/user/1231-nathanwillis">Nathan Willis</a>
		      </h3>

		      		      <p><p><span style="color: #222222; font-family: arial, sans-serif; font-size: 12.800000190734863px;">Nathan Willis is an award-winning documentary filmmaker based in the American South. He has created documentaries for MSNBC, Vice, Fusion, and the Academy Award winning production company, Participant Media.</span></p></p>
		      
		      
		      
					<!-- K2 Plugins: K2UserDisplay -->
					
		    </div>
  		</div>
  	</div>

    
  </div>
  
  
	
  
	<div class="clr"></div>

  
  
  
  <!-- Plugins: AfterDisplay -->
  
  <!-- K2 Plugins: K2AfterDisplay -->
  
  
 
		<div class="itemBackToTop">
		<a class="k2Anchor" href="/item/1119-til-the-day-i-die-bud-welch#startOfPageId1119">
					</a>
	</div>
	
	<div class="clr"></div>
	</div>
</div>
<!-- End K2 Item Layout -->

<!-- JoomlaWorks "K2" (v2.7.1) | Learn more about K2 at http://getk2.org -->
		</div>
		<!-- //MAIN CONTENT -->

		<!-- SIDEBAR RIGHT -->
		<div class="t3-sidebar t3-sidebar-right col-xs-12 col-sm-4  col-md-3 ">
			<div class="t3-module module " id="Mod428"><div class="module-inner"><div class="module-ct"><div class="bannergroup">

	<div class="banneritem">
																																																															<a
							href="/component/banners/click/163" target="_blank"
							title="Submissions open now through March 30 | OA Jeff Baskin Fellowship">
							<img
								src="http://www.oxfordamerican.org/images/banners/OA_BaskinFellowship2017_300x250.jpg"
								alt="Submissions open now through March 30 | OA Jeff Baskin Fellowship"
								width ="300"								height ="250"							/>
						</a>
																<div class="clr"></div>
	</div>

</div>
</div></div></div><div class="t3-module module " id="Mod439"><div class="module-inner"><div class="module-ct"><div class="bannergroup">

	<div class="banneritem">
																																																															<a
							href="/component/banners/click/171" target="_blank"
							title="Roy Orbison BLACK &amp; WHITE NIGHT | Now Available from Amazon">
							<img
								src="http://www.oxfordamerican.org/images/banners/Sony_RoyOrbison_300x250_AMAZON.jpg"
								alt="Roy Orbison BLACK & WHITE NIGHT | Now Available from Amazon"
								width ="300"								height ="250"							/>
						</a>
																<div class="clr"></div>
	</div>

</div>
</div></div></div><div class="t3-module module " id="Mod432"><div class="module-inner"><div class="module-ct"><div class="bannergroup">

	<div class="banneritem">
																																																															<a
							href="/component/banners/click/165" target="_blank"
							title="Christenberry: In Alabama at the Mobile Museum of Art">
							<img
								src="http://www.oxfordamerican.org/images/banners/MobileMuseumofArt_Christenberry_300x250.png"
								alt="Christenberry: In Alabama at the Mobile Museum of Art"
								width ="300"								height ="250"							/>
						</a>
																<div class="clr"></div>
	</div>

</div>
</div></div></div><div class="t3-module module " id="Mod433"><div class="module-inner"><div class="module-ct"><div class="bannergroup">

	<div class="banneritem">
																																																															<a
							href="/component/banners/click/166" target="_blank"
							title="Elvis Ignited | Now Available from University of Florida Press">
							<img
								src="http://www.oxfordamerican.org/images/banners/UniversityPressofFlorida_Mar2017_ElvisIgnited_300x250.jpg"
								alt="Elvis Ignited | Now Available from University of Florida Press"
								width ="300"								height ="250"							/>
						</a>
																<div class="clr"></div>
	</div>

</div>
</div></div></div><div class="t3-module module " id="Mod431"><div class="module-inner"><div class="module-ct"><div class="bannergroup">

	<div class="banneritem">
																																																															<a
							href="/component/banners/click/164" target="_blank"
							title="The 2017 Steel Horse Rally in Fort Smith | Learn More">
							<img
								src="http://www.oxfordamerican.org/images/banners/FortSmithCVB_TheSteelHorseRallyMay2017_300x250.png"
								alt="The 2017 Steel Horse Rally in Fort Smith | Learn More"
								width ="300"								height ="250"							/>
						</a>
																<div class="clr"></div>
	</div>

</div>
</div></div></div><div class="t3-module module " id="Mod414"><div class="module-inner"><div class="module-ct"><div class="bannergroup">

	<div class="banneritem">
																																																															<a
							href="/component/banners/click/149" target="_blank"
							title="Oxford Conference for the Book | March 29-31, 2017">
							<img
								src="http://www.oxfordamerican.org/images/banners/VisitOxford_ConfForTheBook2017_300x250.png"
								alt="Oxford Conference for the Book | March 29-31, 2017"
								width ="300"								height ="250"							/>
						</a>
																<div class="clr"></div>
	</div>

</div>
</div></div></div><div class="t3-module module " id="Mod436"><div class="module-inner"><div class="module-ct"><div class="bannergroup">

	<div class="banneritem">
																																																															<a
							href="/component/banners/click/168" target="_blank"
							title="BO BARTLETT: AMERICAN ARTIST at the Mennello Museum of American Art">
							<img
								src="http://www.oxfordamerican.org/images/banners/MennelloMuseumofAmericanArt_Bartlett_300x250.gif"
								alt="BO BARTLETT: AMERICAN ARTIST at the Mennello Museum of American Art"
								width ="300"								height ="250"							/>
						</a>
																<div class="clr"></div>
	</div>

</div>
</div></div></div><div class="t3-module module " id="Mod437"><div class="module-inner"><div class="module-ct"><div class="bannergroup">

	<div class="banneritem">
																																																															<a
							href="/component/banners/click/169" target="_blank"
							title="NOTES OF BLUE by Sun Volt | Available Now!">
							<img
								src="http://www.oxfordamerican.org/images/banners/ThirtyTigers_SonVolt_300x600.png"
								alt="NOTES OF BLUE by Sun Volt | Available Now!"
								width ="300"								height ="600"							/>
						</a>
																<div class="clr"></div>
	</div>

</div>
</div></div></div><div class="t3-module module " id="Mod438"><div class="module-inner"><div class="module-ct"><div class="bannergroup">

	<div class="banneritem">
																																																															<a
							href="/component/banners/click/170" target="_blank"
							title="April 8-9, 2017 | Baton Rouge Blues Festival">
							<img
								src="http://www.oxfordamerican.org/images/banners/BatonRougeBluesFestival_2017_300x250.gif"
								alt="April 8-9, 2017 | Baton Rouge Blues Festival"
								width ="300"								height ="250"							/>
						</a>
																<div class="clr"></div>
	</div>

</div>
</div></div></div><div class="t3-module module " id="Mod434"><div class="module-inner"><div class="module-ct"><div class="bannergroup">

	<div class="banneritem">
																																																															<a
							href="/component/banners/click/167" target="_blank"
							title="Southern Avenue | Memphis Originals">
							<img
								src="http://www.oxfordamerican.org/images/banners/MemphisCVB_March2017_300x250.jpg"
								alt="Southern Avenue | Memphis Originals"
								width ="300"								height ="250"							/>
						</a>
																<div class="clr"></div>
	</div>

</div>
</div></div></div><div class="t3-module module " id="Mod418"><div class="module-inner"><div class="module-ct"><div class="bannergroup">

	<div class="banneritem">
																																																															<a
							href="/component/banners/click/153" target="_blank"
							title="The Best Blues Experience on the Planet! | Learn More">
							<img
								src="http://www.oxfordamerican.org/images/banners/LegendaryRhythmAndBluesCruise_300x250.gif"
								alt="The Best Blues Experience on the Planet! | Learn More"
								width ="300"								height ="250"							/>
						</a>
																<div class="clr"></div>
	</div>

</div>
</div></div></div><div class="t3-module module " id="Mod409"><div class="module-inner"><div class="module-ct"><div class="bannergroup">

	<div class="banneritem">
																																																															<a
							href="/component/banners/click/141" target="_blank"
							title="Delta Regional Authority | Learn More">
							<img
								src="http://www.oxfordamerican.org/images/banners/DeltaRegionalAuthority_300x250.jpg"
								alt="Delta Regional Authority | Learn More"
								width ="300"								height ="250"							/>
						</a>
																<div class="clr"></div>
	</div>

</div>
</div></div></div><div class="t3-module module " id="Mod405"><div class="module-inner"><div class="module-ct"><div class="bannergroup">

	<div class="banneritem">
										<iframe src="/images/banners/AlabamaTourism_FOOD/index.html" width="300" height="250" scrolling="no" frameBorder='0'></iframe>				<div class="clr"></div>
	</div>

</div>
</div></div></div><div class="t3-module module " id="Mod423"><div class="module-inner"><div class="module-ct"><div class="bannergroup">

	<div class="banneritem">
																																																															<a
							href="/component/banners/click/158" target="_blank"
							title="Visit South Walton | Learn More">
							<img
								src="http://www.oxfordamerican.org/images/banners/VisitSouthWalton_Bike2017_300x250.jpg"
								alt="Visit South Walton | Learn More"
								width ="300"								height ="250"							/>
						</a>
																<div class="clr"></div>
	</div>

</div>
</div></div></div><div class="t3-module module " id="Mod282"><div class="module-inner"><div class="module-ct"><div class="bannergroup">

	<div class="banneritem">
																																																															<a
							href="/component/banners/click/28" target="_blank"
							title="Join the Oxford American Society">
							<img
								src="http://www.oxfordamerican.org/images/banners/OASOCIETYBADGE.jpg"
								alt="Join the Oxford American Society"
								width ="300"								height ="250"							/>
						</a>
																<div class="clr"></div>
	</div>

</div>
</div></div></div>
                            <!-- current-issue -->
                <div class="col-xs-12 current-issue hidden-sm hidden-md hidden-lg">
                    

<div class="custom"  >
	<h4><span style="font-size: 15pt;"><strong><br /><a href="/magazine/itemlist/category/180-issue-96-spring-2017" target="_blank">2017 SPRING ISSUE</a></strong></span></h4>
<div>&nbsp;</div>
<div style="text-align: right;">Three micro-memoirs<strong>&nbsp;</strong>by <strong>Beth Ann Fennelly </strong></div>
<div style="text-align: right;"><a href="/magazine/item/1106-a-town-under-trial">A Town Under Trial, by <strong>Nick Tabor</strong></a></div>
<div style="text-align: right;"><strong>Kiese Laymon </strong>remembers<strong> Margaret Walker</strong></div>
<div style="text-align: right;"><em>Flayed</em>, a story by <strong>Jesmyn Ward</strong></div>
<div style="text-align: right;"><span style="text-align: right;"><strong>Brian Blanchfield </strong>reads&nbsp;Guy Davenport</span><strong><br /></strong></div></div>

                </div>
                <!-- //current-issue -->
                
                            <!-- book -->
                <div class="col-xs-12 book hidden-sm hidden-md hidden-lg">
                    

<div class="custom"  >
	<a href="/magazine/itemlist/category/180-issue-96-spring-2017" target="_blank"><img src="/images/_ISSUECOVERS/_Module%20covers/OA96_COVER_module.jpg" alt="OA96 COVER module" /></a></div>

                </div>
                <!-- //book -->
                
            
		</div>
		<!-- //SIDEBAR RIGHT -->

	</div>
</div></div></div> 



  
	<!-- SPOTLIGHT 2 -->
    
	<div class=" t3-sl t3-sl-2">
    	<div class="container">
				<!-- SPOTLIGHT -->
	<div class="t3-spotlight t3-spotlight-2  row">
					<div class=" col-lg-12 col-md-12 col-sm-12 col-xs-12">
								<div class="t3-module module footertext " id="Mod110"><div class="module-inner"><div class="module-ct">

<div class="custom footertext"  >
	<div style="float: left; width: 80%;">
<h5><a href="/advertise">ADVERTISE</a> | <a href="/press-room">PRESS ROOM</a> | <a href="/privacy-policy">PRIVACY POLICY</a> | <a href="https://www.z2systems.com/np/clients/oxford/donation.jsp" target="_blank">DONATE</a></h5>
</div>
<div style="float: right; width: 20%; color: #999;">
<h6> <a href="http://www.pixelperfectcreative.com" target="_blank" style="color: #999;">BUILT BY PIXEL PERFECT</a></h6>
</div></div>
</div></div></div>
							</div>
			</div>
<!-- SPOTLIGHT -->
        </div>
	</div>
	<!-- //SPOTLIGHT 2 -->


  


  
<!-- FOOTER -->
<footer id="t3-footer" class="wrap t3-footer">

	
    <!-- BACK TO TOP -->
    <div id="back-to-top" class="back-to-top t3-hide">
    <i class="fa fa-angle-double-up"></i>
    </div>
    <script type="text/javascript">
  //<![CDATA[
  (function($){
    $(document).ready(function(){
      $('#back-to-top').click(function(){
        if($(this).hasClass('reveal')){
          $('html, body').stop(true).animate({
            scrollTop: 0
          });
        }
      });

      $(window).scroll(function(){
        $('#back-to-top')[$(window).scrollTop() > 0 ? 'addClass' : 'removeClass']('reveal');
      });
    });
  })(jQuery);
  //]]>
</script>

</footer>
<!-- //FOOTER -->

</div>

</body>

</html>